Foodsoft packaging: libssl1.0-dev and Ruby 2.3.8

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Foodsoft packaging: libssl1.0-dev and Ruby 2.3.8

decentral1se
So, I've discovered in my packaging efforts that Ruby 2.3.x requires the old libssl-1.0-dev (I'm on Debian Stretch).

That conflicts with the ususal libssl-dev which most other packages need and require. I'm using this solution:

  * https://github.com/rvm/rvm/issues/3862#issuecomment-277512130

So, I am wondering about the compatibility with Ruby 2.3. Is it possible to use a more recent version of Ruby?

That would help me alot to know if anyone has tried it before. Or if it can be supported in some way.

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Foodsoft packaging: libssl1.0-dev and Ruby 2.3.8

wvengen
Administrator

I don't remember precisely, but I should think using a recent Ruby-version is fine. You might encounter some warnings, though.
We also have some dependencies that don't work with newer versions, which may not work perfectly with newer Ruby versions (rails-settings-cached).
On my development machine, I use Ruby 2.4.

- Willem

On 30-07-19 18:32, decentral1se [via foodsoft] wrote:
So, I've discovered in my packaging efforts that Ruby 2.3.x requires the old libssl-1.0-dev (I'm on Debian Stretch).

That conflicts with the ususal libssl-dev which most other packages need and require. I'm using this solution:

  * https://github.com/rvm/rvm/issues/3862#issuecomment-277512130

So, I am wondering about the compatibility with Ruby 2.3. Is it possible to use a more recent version of Ruby?

That would help me alot to know if anyone has tried it before. Or if it can be supported in some way.

Thanks!


If you reply to this email, your message will be added to the discussion below:
http://foodsoft.51229.x6.nabble.com/Foodsoft-packaging-libssl1-0-dev-and-Ruby-2-3-8-tp2752.html
To start a new topic under foodsoft-dev, email [hidden email]
To unsubscribe from foodsoft-dev, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Foodsoft packaging: libssl1.0-dev and Ruby 2.3.8

decentral1se