Quantcast

problem updating foodsoft-adam

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem updating foodsoft-adam

Antilopa
Hi,

I finaly got around to updating my foodsof installation from Foodsoft v3.3.7+adam+ß to Foodsoft v3.3.9+adam+ß (installed in development mode), but it doesn't work as expected.

When addind a product to my order, the tolerance bar moves as it should, but when clicking to review the overview the tolerance bar just goes back to zero (while the products are still there). Other users also do not see any change to the tolerance bar, as it doesn't change globally. If I am not being clear enough, you can see what I mean in the image below.



Not sure what I am missing to make it work and I didn't find anything usefull in the logs. Any idea?

one more side question: I read somewhere that foodsoft-adam fork is to be merged with master, I was wondering if this is done and if I should just go ahead and install foodsoft instead.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem updating foodsoft-adam

wvengen
Administrator
Hi,

Thanks for mailing, this looks like a bug on the server-side. Hope to have some time to investigate it this week.

Regarding merging foodcoop-adam's fork with upstream, that is indeed in the works, but as you might be able to guess from foodcoop-adam/foodsoft#163 [1], it'll take quite some time. So for you you'd better keep using foodcoop-adam's fork, if these are the features you want.

Best,
- Willem

[1] https://github.com/foodcoop-adam/foodsoft/issues/163

On 24-01-16 14:45, Antilopa [via foodsoft] wrote:
Hi,

I finaly got around to updating my foodsof installation from Foodsoft v3.3.7+adam+ß to Foodsoft v3.3.9+adam+ß (installed in development mode), but it doesn't work as expected.

When addind a product to my order, the tolerance bar moves as it should, but when clicking to review the overview the tolerance bar just goes back to zero (while the products are still there). Other users also do not see any change to the tolerance bar, as it doesn't change globally. If I am not being clear enough, you can see what I mean in the image below.



Not sure what I am missing to make it work and I didn't find anything usefull in the logs. Any idea?

one more side question: I read somewhere that foodsoft-adam fork is to be merged with master, I was wondering if this is done and if I should just go ahead and install foodsoft instead.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem updating foodsoft-adam

wvengen
Administrator
In reply to this post by Antilopa
Hi,

I cannot reproduce this. Does the installation at https://order.foodcoopamsterdam.nl/foodsoft/demo/ work for you? (Login with default admin account credentials.) If not, then it's a client-side issue; if yes, it's on your server.
You did run any migrations, I presume?

Let's take this discussion to an issue, please open one at - https://github.com/foodcoop-adam/foodsoft/issues/new
and reference this discussion with http://foodsoft.51229.x6.nabble.com/problem-updating-foodsoft-adam-td1189.html

- Willem

On 24-01-16 14:45, Antilopa [via foodsoft] wrote:
Hi,

I finaly got around to updating my foodsof installation from Foodsoft v3.3.7+adam+ß to Foodsoft v3.3.9+adam+ß (installed in development mode), but it doesn't work as expected.

When addind a product to my order, the tolerance bar moves as it should, but when clicking to review the overview the tolerance bar just goes back to zero (while the products are still there). Other users also do not see any change to the tolerance bar, as it doesn't change globally. If I am not being clear enough, you can see what I mean in the image below.



Not sure what I am missing to make it work and I didn't find anything usefull in the logs. Any idea?

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem updating foodsoft-adam

Antilopa
I tested it on the demo installation and had the same results. Checked on mulitple browsers and two different machines.
I made an issue here:
https://github.com/foodcoop-adam/foodsoft/issues/175

Loading...